bcl2fastq

module (bold = default) build dependencies
bcl2fastq/2.19.1.403/b1 gcc

also see Using Software.