japsa

module (bold = default) build dependencies
japsa/1.6 java

also see Using Software.