biopython

module (bold = default) build dependencies
biopython/1.64 gcc 4.4.7 numpy/1.7.1/b1 python/2.7.6

also see Using Software.