fftw3

module (bold = default) build dependencies
fftw3/3.3.4/b1 gcc 4.4.7, openMPI 1.6.5 openmpi/1.6.5/b1
fftw3/3.3.4/b2 intel 2013.1.046, openMPI 1.6.5 openmpi/1.6.5/b2
fftw3/3.3.4/b3 intel 2013.0.046 impi/4.1.3.048 impi/4.1.3.048
fftw3/3.3.4/b4 gcc 5.2.0, openMPI 1.10.2 openmpi/1.10.2
fftw3/3.3.4/b5 gcc 5.2.0

also see Using Software.