hypre

module (bold = default) build dependencies
hypre/2.10.1/b1 gcc 5.2.0
hypre/2.11.2/b1 impi/2017.0516b
hypre/2.9.0b/b1 intel 14.0.2
hypre/2.9.0b/b2 gcc 4.4.7
hypre/2.9.0b/b3 intel 14.0.2 impi/4.1.3.048

also see Using Software.