magma

module (bold = default) build dependencies
magma/1.7.0/b1 gcc 4.4.7, cuda 7.5 openblas/0.2.14/b1 cuda/7.5

also see Using Software.