zlib

module (bold = default) build dependencies
zlib/1.2.8/b1 gcc 4.4.7 openmpi/1.6.5/b1
zlib/1.2.8/b2 gcc 5.2.0 openmpi/1.10.2/b1
zlib/1.2.8/b3 gcc 4.4.7

also see Using Software.