fenics

module (bold = default) build dependencies
fenics/2016.1.0 mpfr/3.1.2/b1 python/2.7.11/b1 eigen/3.2.8 boost/1.59.0 swig/3.0.10 openmpi/1.10.2/b3 gmp/6.0.0a/b2

also see Using Software.