octave

module (bold = default) build dependencies
octave/3.8.1/b1 gcc 4.4.7 blas/2011/b1 xblas/1.0.248/b1 texinfo/5.2/b1 python/2.7.6 libgd/2.1.0/b2 gnuplot/4.6.5/b1 fftw3/3.3.4/b1 hdf5/1.8.12/b6 suitesparse/4.2.1/b2 arpack/96/b2 gperf/3.0.4/b1 qhull/2012.1/b1 glpk/4.54/b1 fltk/1.3.2/b1 freeglut/2.8.1/b1 gl2ps/1.3.8/b1 qrupdate/1.1.2/b2 lapack/3.5.0/b1

also see Using Software.