petsc

module (bold = default) build dependencies
petsc/3.7.3/b1 openmpi/2.0.0/b1 blas/2011/b1 lapack/3.5.0/b1

also see Using Software.