bazel

module (bold = default) build dependencies
bazel/0.4.5 jdk/1.8.0_111
bazel/0.5.4 jdk/9-ea

also see Using Software.