openmpi

module (bold = default) build dependencies
openmpi/1.10.2/b1 gcc 5.2.0 gcc/5.2.0
openmpi/1.10.2/b2 intel 2016.0515 intel/2016.0515
openmpi/1.10.2/b3 gcc 4.9.3 gcc/4.9.3
openmpi/1.10.3/b1 gcc 4.4.7, cuda 7.5 cuda/7.5
openmpi/1.6.5/b1 gcc-4.4.7
openmpi/1.6.5/b2 intel 2013.1.046 intel/2013.1.046
openmpi/2.0.0/b1 gcc 4.4.7
openmpi/2.0.0/b2 intel 2016.0515 intel/2016.0515b
openmpi/2.0.1/b1 gcc 4.4.7
openmpi/2.0.1/b2 intel 2017.0516 intel/2017.0516
openmpi/2.0.1/b3 gcc 4.9.4 gcc/4.9.4
openmpi/2.0.1/b4 gcc 5.4.0 gcc/5.4.0
openmpi/2.0.2/b1 gcc 4.4.7

also see Using Software.