pycuda

module (bold = default) build dependencies
pycuda/2014.1 python/2.7.9/b1 boost/1.58.0/b1 cuda/5.5/b1
pycuda/2015.1.3 python/2.7.10/b1 cuda/7.5

also see Using Software.