boost

module (bold = default) build dependencies
boost/1.58.0/b1 gcc 5.4.0 gcc/5.4.0
boost/1.62.0/b1 gcc 4.8.5

also see Using Software.